
 

    Insights  

 
 

The source for news and tips of interest to users of MSC-LIMS,  
an affordable laboratory information management system for small labs. 

Issue No. 29  January 2018 

 

January, 2018  Page 1 of 7 

MMSSCC--LLIIMMSS  

TTMM

  

  

 

Welcome 
Welcome to MSC-LIMS Insights.   

 
This newsletter will help current MSC-LIMS users 

get the most out of their software, and will 

complement the product literature and demo 
that prospective users can find on our web site 

at www.msc-lims.com.   
 

Join our mailing list for more information.  Sign up at www.msc-lims.com/lims/maillist.html. 

 
This newsletter is for and about MSC-LIMS users.  We welcome your comments, and your suggestions for topics you 

would like to see addressed in upcoming issues.  Please send your thoughts to newsletter@msc-lims.com.    
 

Disabling or Altering High, Low, and 
BDL Warnings 
When reporting analysis results, MSC-LIMS will automatically append the 
characters "H" or "L" (for high and low) adjacent to the analysis' result 

value if the value is greater than or less than the analysis' warning limit.  
The characters “BDL” are reported when the result value is below the 

analysis’ detection limit. 
 

These warning characters can be modified or disabled entirely by adding 

a setting to the Options tab of the System Configuration screen.  
Following are the available options: 

 

Option Value Data 
gbFormatAnalysisResult 0 to disable 

-1 to enable 
Not used 

gsFormatAnalysisResultBDL Not used The text to insert in place of the 
result value when the value is 
below the detection limit 
(default = "BDL") 

gsFormatAnalysisResultHigh Not used The text to append to the result 
value (default = " H") 

gsFormatAnalysisResultLow Not used The text to append to the result 
value (default = " L") 

 
Simply add the appropriate option name and value or data to a new 

record on the Options tab of the System Configuration screen then exit  
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From the Developer 
Periodically, we receive a copy of a user’s LimsData database to use when testing one of their custom Excel templates 

or for other troubleshooting purposes. After I receive a LimsData file I first compact the database before using it in 
any testing.  A successful compact assures the integrity of the database.  I then compare the size of the database 

before and after compacting.  Frequently, there is a substantial reduction in the file’s size, which suggests the 

database has not been compacted in some time.  Occasionally, after discussion, I learn the database is rarely if ever 
compacted. 

 
We recommend compacting your LimsData database weekly if you can or at least monthly.  In addition to verifying 

the integrity of the database, regular compacting will improve MSC-LIMS’ performance.  Compacting the database 

creates a new database file from the existing file and in the process rewrites all the database tables in primary key 
order, recreates all table indexes, and updates database statistics, all of which improve overall database performance. 

 
With upcoming MSC-LIMS version 5.0 and its SQL Server backend database, maintenance tasks will differ.  Until then, 

if you haven’t already done so, we encourage you to implement routine LimsData compacting. 

       
Rick Collard is the founder of Mountain States Consulting, LLC and the principal developer of the MSC-LIMS software.  
You can reach Rick by email at rcollard@msc-lims.com. 
 
 

MSC-LIMS and SQL Server 
As we announced in previous issues of this newsletter 

we are currently developing MSC-LIMS version 5.0 for 
SQL Server.  MSC-LIMS 5.0 replaces the earlier Access 

back end database (LimsData) with a SQL Server 
database for improved reliability, scalability, and 

security.  Below are answers to more questions to help 

you understand and prepare for the new version. 
 

How will my existing data be preserved? 
All data from your current production LimsData 

database can be migrated to a SQL Server database.  

Data from archive databases can also be migrated to a 
separate SQL Server database and that data will 

remain read-only. 
 

Multiple steps are required to migrate an MSC-LIMS 
version 4.1 Access database to SQL Server.  First, a full 

copy of Microsoft Access is used to remove security on 

the database and run a script to prepare the database.  
Next, Microsoft’s SQL Server Migration Assistant for 

Access converts and copies the data from the Access 
database to a new SQL Server database.  Finally, 

another script is run within the SQL Server 

Management Studio to update the new database and 
add all the components required by the new version of 

MSC-LIMS.  Detailed documentation will be provided to 
migrate the data.  However, we will also provide a 

data migration service for those who prefer to have 

MSC transfer their data. 
 

Can I have multiple SQL Server databases? 
Yes.  Just like you can in current versions of MSC-LIMS 

you can maintain multiple LIMS SQL Server databases 

for distinct departments, locations, or companies.  The 
File menu’s Open LIMS Database option will allow you 

to switch between databases just as you currently can.  
And the File menu’s list of recent databases makes 

switching databases simple. 

 
Will archiving still be available? 

MSC-LIMS Archiving will no longer be available.  The 
main purpose of Archiving was to move older sample 

data from the production database to an archive 
database to improve performance of the production 

database.  SQL Server databases do not suffer from 

performance degradation common with large Access 
databases so most users will never have a need to 

archive.  However, an entire database is easily copied 
in SQL Server so some may use this approach to 

creating their own archives. 

 
(Continued on next page) 
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How will database backup and maintenance 

change? 
Database backup and other maintenance tasks will be 

performed within SQL Server Management Studio.  The 
updated MSC-LIMS User’s Guide will have instructions 

for these tasks. 
 

 
 

What is Windows Authentication? 

Windows authentication is the default integrated 
security model in SQL Server and is tightly integrated 

with Windows.  With Windows authentication, specific 
Windows user accounts are trusted to log in to SQL 

Server so authorized users can start MSC-LIMS without 
any additional login.  The LIMS administrator(s) will 

still control who has access to MSC-LIMS, but this is 

managed by adding existing Windows user accounts to 

the Users setup screen.  

 

Use Conditional Formatting in Excel Templates 
Excel’s cell formatting options such as number, 

currency, decimal places, alignment, and font 
determine how a cell’s value is displayed.  Conditional 

formatting is more flexible allowing specific formatting 

to apply only under certain conditions.  Following are 
three ways you can employ conditional formatting in 

your Excel templates. 
 

1. Shade Alternate Rows 
Adding shading to alternate rows of long or wide lists 

of data makes such lists easier to view.  To give it a 

try, first make a copy of the CofA Example export 
template then open the new copy.  Select the 

OneAnalysisResults named range from the Name box 
(i.e. the pick list just above the intersection of row and 

columns labels).  On the Home tab in the Styles group 

select Conditional Formatting then click New Rule.  
Select 'Use a formula to determine which cells to 

format', enter the formula =MOD(ROW(), 2) then 

click the Format button and add a light fill color. 

 

 

The template’s macro copies the OneAnalysisResults 

named range once for each analysis exported to the 
template and the formula in our new conditional 

formatting rule will be true only on odd numbered 

rows.  Save and close the template then export a 
Sample Summary report and you will now have 

alternate shaded rows. 
 

 
 
2. Suppress Repeating Values 

When a list includes repeating values such as the 
sample ID in a list of the sample’s analyses, we can 

suppress the repeating values with a conditional 

format using a white font on a white background.  To 
follow this example, begin by making a copy of the 

Final Report Example export template then open the 
new copy. 

 
(Continued on next page)
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Increase the width of column E then enter the 

following formula in cell E25: 
 
=INDEX(CustomerSampleID, MATCH(A25, 

SampleID,0)) 

 
The formula above uses the sample ID in column A to 

look up the sample’s CustomerSampleID field value.  
You can replace CustomerSampleID in the formula 

with another valid sample characteristic field name 
such as Location.Name, SampleType.Name, 

Description, CollectedDate, etc.  Note that cell E25 falls 

within row 25’s OneAnalysisResults named range that 
the template’s macro copies for each analysis exported 

so our new formula will automatically be copied.   
 

With cell E25 still selected, choose Conditional 

Formatting on the Home tab then click New Rule.  
Select 'Use a formula to determine which cells to 

format', enter the formula =A25 = A24 then click the 

Format button and change the font color from 

Automatic to white.  Click OK to save the new rule.  
Now select Conditional Formatting on the Home tab 

again, select Manage Rules then select This Worksheet 
from the pick list to view all conditional formatting 

rules in this worksheet.  The screen below shows that 

both the new rule in cell E25 and an existing rule in 
cell A25 use a white font on a white background to 

“hide” repeating values.  Use this Rules Manager 
screen to add, edit, and delete conditional formatting 

rules. 

 

  
 

Save and close the template then export a multiple-
sample Sample Summary report and verify that any 

repeating values are now suppressed. 

 
 

  
 

Select all the cells with repeating values and you can 
see that each cell actually has a value and only 

formatting makes it appear empty. 
 

 
 
3. Highlight Values Out of Range 

You can also use conditional formatting to bring 

attention to values that are out of range or 
specification.  The screen below shows example 

project analysis specifications.  We can use conditional 
formatting to easily identify any results that are above 

the specified warning maximum. 
 

  
(Continued on next page) 
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To follow this example, open the same template used 

in the previous example. At column P insert two new 
columns then copy the following formula from cell P25 

to cells N25 and O25: 
 
=IF(ISBLANK(INDEX(AnalysisResultFormatted, 

ROW() - ROW(OneAnalysisResults) + 1)), 

"",INDEX(AnalysisResultFormatted, ROW() - 

ROW(OneAnalysisResults) + 1)) 

 
In cell N25’s formula, change the two occurrences of 

‘AnalysisResultFormatted’ to ‘AnalysisResult’.  In cell 

O25’s formula, change the two occurrences of 
‘AnalysisResultFormatted’ to ‘WarningMax’.  Now select 

cell P25, choose Conditional Formatting on the Home 
tab then click New Rule.  Select 'Use a formula to 

determine which cells to format', enter the formula 

=N25 > O25 then click the Format button and change 

the font to bold with color red.  Click OK to save the 
new rule. 

 

  
 

 
Hide columns N and O, save and close the template 

then export a multiple-sample Sample Summary report 

and any result values out of range will appear in red. 
 

  
 
Explore Excel’s conditional formatting and discover 

more ways to highlight and visualize data on your 

reports.  
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Notes from Technical Support

Printing More Than 10 Sample Labels 

A user recently noted: 
 

We just tried to print 11 labels for a sample but got an 
error message that only 1-10 labels are allowed.   
 

The label Quantity field on both the Sample Container 
Labels and Select or Build Label Script screens has a 

maximum of 10 to prevent inadvertently printing too 

many labels.  To print more than 10 labels you can 
perform multiple prints to achieve the required 

quantity.  However, you can also use a Label Script to 
bypass the Quantity field’s limit.  You can either build 

and save a label script using the Label Scripts screen 
on the Setup menu or you can dynamically build the 

script.  If you let the build screen add Quantity=1 to 

the script you can change the quantity to any number.  
The label script to print 11 Default style labels is: 

 

Style=Default, Quantity=11     

Invoiced vs. Un-invoiced Samples 

A user recently asked: 
 

I am creating an excel file with all un-invoiced samples 
to import into QuickBooks. The first I did this, I did not 
allow the LIMS to update the invoice number. I went in 
manually and put an invoice number in for all of the 
samples listed on the Excel file. This did not work as 
the next time I ran the report I got all of the same 
samples in addition to the new samples that needed to 
be invoiced. Can you help me out, please? 
 
When you enable either the Invoiced or Uninvoiced 

options on the Additional tab of the query controls, the 
LIMS adds a query criterion using the sample’s Invoice 

Date field to find the requested samples.  You can see 

the criterion by clicking the SQL tab of the query 
controls after clicking the Query button.  With Invoiced 

enabled the LIMS adds an InvoiceDate IS NOT 

NULL criterion and with Uninvoiced enabled an 

InvoiceDate IS NULL criterion is used. 

 

To fix the problem, use the Sample Login screen in 
edit mode and add an Invoice Date to the samples you 

already invoiced and they will now be invoiced rather 

than un-invoiced samples.  

How to Report Re-analysis Data 

A user recently submitted this question: 
 

Occasionally, a client asks us to repeat an analysis of 
analyte for various reasons.  We don’t want to over-
write the original data.  That would be illegal in our 
industry. Ideally, we’d like to keep the same MSC-LIMS 
sample ID and report the re-analysis data on the same 
page as the original data.   
 
First, I added a duplicate LIMS analyte but it was 
confusing because it wasn’t clearly identified as a re-
analysis (the only differentiating field was the analysis 
date because the results between the original and 
second analysis were similar).  I created an analyte 
named “Copper, reanalysis” which works but I don’t 
want to create a couple hundred analytes that would 
be rarely used.  Do you have any suggestions how to 
handle this situation? 
 

A simple solution is to flag the duplicate analysis’ result 

as a re-analysis.  First, use the Result Types setup 
screen on the Setup menu and add a new result type 

with a symbol of your choice to identify a result as a 
re-analysis.  Next, add a description for the symbol to 

your Excel final report template(s).  Now whenever 

you repeat an analysis, add the duplicate analysis to 
the sample then select the re-analysis result type when 

entering the result value for the duplicate analysis.  

Database Size Warning 

After seeing a warning at startup, a user asked: 

 
We just had an error flash on the screen when logging 
in that the database had reached its limit.  It appears 
to still be working and I will compact the database 
again this evening.  Is there an upper limit to the 
database? 
 

It is unlikely the message was about your LimsData 
database, which has a 2GB size limit.  The message 

was probably about the size of LimsCode.  The 

LimsCode size warning is a remnant from one of the 
earliest versions of MSC-LIMS, back when PCs were 

much slower where an unnecessarily large LimsCode 
could affect system performance.  To eliminate the 

 

(Continued on next page)
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warning, open the Workstation Configuration screen on 

each LIMS workstation and make sure the "Compact 
LimsCode at exit" and "Delete temporary records at  

 
 

 
 

exit" options are enabled then increase the compact 

startup warning threshold to 30 MB.  That should 

suppress the message.  

 

 
Disabling or Altering High, Low, and BDL Warnings 
(Continued from page 1)  

 
and restart the LIMS for the option to take effect.  

Note that you can use the Inactivate check box to 
inactivate an option you want to leave in the screen for  

 

 

 
future reference.  See file MSC-LIMS SysCfg 

Options.doc in the File Library for more information 

and a complete list of available options. 

 

For Customers Only 
This section of MSC-LIMS Insights is devoted to current users of MSC-LIMS.  Here we briefly introduce only the most 
recent additions to MSC-LIMS.com Customers Only pages. Use your login name and password to log on to the 

Customers Only section of our website.

MSC-LIMS Insights Archive 

All past issues of MSC-LIMS Insights are archived on 

our web site and accessible to current MSC-LIMS 
users.  You will find valuable tips, techniques, and 

technical articles to help you get the most out of your 
MSC-LIMS implementation.  Use your browser’s search 

function to locate topics in the article index.  

 
 

 

 

 

 
 

 
 

 

 
 

 
 

 

Contact Us 
Questions, comments, suggestions?  
Reach us at: 
 

Mountain States Consulting, LLC 
970 West Broadway #471 
PO Box 30000 
Jackson, Wyoming  83002  USA 
Ph  +1 307-733-1442 
Fax +1 303-379-6850 

 
 
 info@msc-lims.com 
 www.msc-lims.com   
 
 
Copyright © 2018 Mountain States Consulting, LLC.   
All rights reserved.  
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